This is how I configured IPv6 address received dynamically from my ISP. This is not to be confused with using a 6to4 tunnel service which is something completely different. In this case, a real IPv6 address is received using DHCP6 or SLAAC from the ISP.
In this setup the IPv6 LAN side is bridged with the IPv6 WAN side, so the LAN subnet is a part of the larger WAN subnet. Firewall rules will apply even though it is a bridged, not routed setup.
Go to WAN -> WAN settings -> IPv6 Settings and select DHCP, check DHCP-PD and enter “0” for Prefix name. Apply.
Go to Status and Statistics -> IPv6 tab and verify that you get a IPv6 address from your provider (starting with 2a02 in my case).
Go to LAN -> VLAN Settings and select vlan 1, click edit button.
In the IPv6 sections, select prefix from WAN 0, in my case address beginning with 2a02 and /48 size. Enter 0 for suffix, 64 for prefix length, leave DHCP Type disabled. Apply.
Go to LAN -> Router advertisment and click Enable, select Unicast, do not select Managed or Other. Make sure the IPv6 prefix is visible in the Prefix table.
WP displays “Connection Information” and a text “To perform the requested operation, WordPress needs to access your web server. Please enter your FTP credentials to proceed. If you do not remember your credentials, you should contact your web host.”
To solve this, add the following line to your wp-config.php:
define('FS_METHOD','direct');
If that doesn’t solve the problem you need to check the file access rights for the WordPress installation on the web server.
If you’ve tried the Windows 10 Enterprise Evaluation and decide to go on and buy the full version, Microsoft doesn’t support a simple way of just converting or upgrading.
This is how you do it.
You will need:
An ISO image of Windows 10 Enterprise, download it from Microsoft (link is not provided here because Microsoft has a tendency to change their URL:s and direct links usually ends up broken, so you just have to search for it at Microsoft). Note: It MUST be for the same language code as the one used when you installed the Evaluation.
A Windows 10 license key.
Start the upgrade using the ISO image but do not continue
In EditionID value data, change EnterpriseEval to Enterprise
In ProductName value, change Windows 10 Enterprise Evaluation to Windows 10 Enterprise
Immediately continue the upgrade while the Registry Editor is still open (otherwise the changed registry values will revert and you will not be able to upgrade).
https://media01.nerdia.net/uploads/nerdia-logo-340x156.png00Stefan Helanderhttps://media01.nerdia.net/uploads/nerdia-logo-340x156.pngStefan Helander2020-11-20 06:27:002021-06-05 06:46:08How to upgrade Windows 10 Enterprise Evaluation to full version
This is a simple how to make a nexus switch L3 routeing and the connected access switches still on L2 switching. If you have a router connected between internet and the router switch. Make shure you have a static route configured to the two vlan network.
Router Switch
no system default interface-vlan autostate (brings up the vlan)
conf t
vlan 10 (creates vlan 10 L2)
name Servers vlan 10
exit
vlan 20 (creates vlan 20 L2)
name Servers vlan 20
exit
feature interface-vlan (Converts L2 vlan 10 to L3 vlan 10)
interface vlan 10
ipv6 address 2001:db8::/50
no ip redirects
exit
feature interface-vlan (Converts L2 vlan 20 to L3 vlan 20)
interface vlan 20
ipv6 address 2001db8:0:4000::/50
no ip redirects
exit
interface ethernet 1/1 (creates tagged vlan port to access sw1)
description To Access Sw1
switchport
switchport mode trunk
no shutdown
exit
interface ethernet 1/2 (creates tagegd vlan port to access sw1)
description to Access Sw2
switchport
switchport mode trunk
no shutdown
exit
interface ethernet 1/3 (Creates the link network port)
description to Internet
no switchport
ipv6 address 2001:db8:1000:8000::1/64
no shutdown
exit
ipv6 route :: 2001:db8:1000:8000::2 (makes default router to next hop router)
copy running-config startup-config
Access Sw1
conf t
vlan 10 (creates vlan 10 L2)
name Servers vlan 10
exit
vlan 20 (creates vlan 20 L2)
name Servers vlan 20
exit
interface ethernet 1/1 (creates tagged vlan port to Router switch)
description To Router Switch
switchport
switchport mode trunk
no shutdown
exit
interface ethernet 1/2 (creates untagged vlan 10 port to servers)
description Access vlan 10
switchport
switchport mode access vlan 10
no shutdown
exit
interface ethernet 1/3 (creates untagged vlan 20 port to servers)
description Access vlan 20
switchport
switchport mode access vlan 20
no shutdown
exit
copy running-config startup-config
Access Sw2
conf t
vlan 10 (creates vlan 10 L2)
name Servers vlan 10
exit
vlan 20 (creates vlan 10 L2)
name Servers vlan 20
exit
interface ethernet 1/1 (creates tagged vlan port to Router switch)
description To Router Switch
switchport
switchport mode trunk
no shutdown
exit
interface ethernet 1/2 (creates untagged vlan 10 port to servers)
description Access vlan 10
switchport
switchport mode access vlan 10
no shutdown
exit
interface ethernet 1/3 (creates untagged vlan 20 port to servers)
This is a simple how to make a nexus switch L3 routeing and the connected access switches still on L2 switching. If you have a router connected between internet and the router switch. Make shure you have a static route configured to the two vlan network.
Router Switch
no system default interface-vlan autostate (brings up the vlan)
conf t
vlan 10 (creates vlan 10 L2)
name Servers vlan 10
exit
vlan 20 (creates vlan 20 L2)
name Servers vlan 20
exit
feature interface-vlan (Converts L2 vlan 10 to L3 vlan 10)
interface vlan 10 ip address 1.1.1.1/24 no ip redirects
exit
feature interface-vlan (Converts L2 vlan 20 to L3 vlan 20) interface vlan 20 ip address 2.2.2.2/24 no ip redirects
exit
interface ethernet 1/1 (creates tagged vlan port to access sw1) description To Access Sw1 switchport switchport mode trunk no shutdown
exit
interface ethernet 1/2 (creates tagegd vlan port to access sw1) description to Access Sw2 switchport switchport mode trunk no shutdown
exit
interface ethernet 1/3 (Creates the link network port) description to Internet no switchport ip address 3.3.3.1/30 no shutdown
exit
ip route 0.0.0.0 0.0.0.0 3.3.3.2 (makes default router to next hop router)
copy running-config startup-config
Access Sw1
conf t
vlan 10 (creates vlan 10 L2)
name Servers vlan 10
exit
vlan 20 (creates vlan 20 L2)
name Servers vlan 20
exit
interface ethernet 1/1 (creates tagged vlan port to Router switch) description To Router Switch switchport switchport mode trunk no shutdown
exit
interface ethernet 1/2 (creates untagged vlan 10 port to servers) description Access vlan 10 switchport switchport mode access vlan 10 no shutdown
exit
interface ethernet 1/3 (creates untagged vlan 20 port to servers) description Access vlan 20 switchport switchport mode access vlan 20 no shutdown
exit
copy running-config startup-config
Access Sw2
conf t
vlan 10 (creates vlan 10 L2)
name Servers vlan 10
exit
vlan 20 (creates vlan 10 L2)
name Servers vlan 20
exit
interface ethernet 1/1 (creates tagged vlan port to Router switch) description To Router Switch switchport switchport mode trunk no shutdown
exit
interface ethernet 1/2 (creates untagged vlan 10 port to servers) description Access vlan 10 switchport switchport mode access vlan 10 no shutdown
exit
interface ethernet 1/3 (creates untagged vlan 20 port to servers) description Access vlan 20 switchport switchport mode access vlan 20 no shutdown
The Joomla! extension iFAQ from Ideal Extensions is a nice way of building a FAQ (Frequently Asked Questions) section on your website.
One feature I am missing though is to be able to select wether a FAQ list of articles should default to all open instead of closed. This is a simple workaround.
Add a module of the type Custom HTML and edit the module content using no editor. Publish the module in a suitable module position, like Debug.
Insert the following javascript into the module (remember, no editor mode):
By selecting which menu items the module is displayed for, you can choose the FAQ pages where you want to have the articles expanded by default.
https://media01.nerdia.net/uploads/nerdia-logo-340x156.png00Stefan Helanderhttps://media01.nerdia.net/uploads/nerdia-logo-340x156.pngStefan Helander2020-10-24 08:40:432020-10-24 08:40:45iFAQ auto expand all [solution]
After maintenance even though setting to shop to active, frontend still shows maintenance mode. This can occur when multistore is enabled.
Solution:
Use for example phpMyAdmin to access the shop database
Find the ps_configuration table
Find all records with the name PS_SHOP_ENABLE and change them from ‘0’ to ‘1’ (there are probably more than one)
https://media01.nerdia.net/uploads/nerdia-logo-340x156.png00Stefan Helanderhttps://media01.nerdia.net/uploads/nerdia-logo-340x156.pngStefan Helander2020-03-19 10:33:332020-03-19 10:33:34Prestashop multistore – can’t get out of maintenance mode
A Joomla article was published through a menu item (single article) but the breadcrumbs when displaying the article only showed “Home” (not clickable). The menu path and article title was missing in the breadcrumbs.
In this case JoomSEF was installed on the site. The solution was to find the SEF URL in JoomSEF (go to “Manage SEF URLs”). The ItemID field was empty.
The problem was solved by entering the menu ID for the menu item displaying the article in the ItemID field, saving and clearing the cache.
https://media01.nerdia.net/uploads/joomla_breadcrumbs_joomsef_itemid.png344715Stefan Helanderhttps://media01.nerdia.net/uploads/nerdia-logo-340x156.pngStefan Helander2020-03-18 10:39:322020-03-18 10:39:33Breadcrumbs only showing “Home” for Joomla article
WordPress just showing a white page means it is experienceing PHP errors. When it occurs after a site has been moved from one hosting to another it can be caused by several reasons.
To make it possible to track down the cause you can temporarily add the following to the .htaccess file in the root. If this gives you a internal server error 500 it means it is not allowed by the host. If allowed, you will get error messages from PHP dispayed on screen when accessing the site:
php_flag display_startup_errors on
php_flag display_errors on
There are visbible PHP ending tags ?> on the site
If you see more or less normal output from the site but once in a while you see lines ending with ?>. This can happen if the site has been running on PHP 5 where the short PHP start tag <? is allowed (instead of the longer <?php.
If the site has been moved to PHP 7 where this is not longer allowed, it can cause this kind of strange behaviour.
If you don’t want to go through all the code and find all the occurrences of <? and replace them with <?php (which is one solution), you can simply add the following to your php.ini:
short_open_tag=On
You need to restart Apache after this.
Wordfence plugin is installed
You need to manually edit the system specific paths in the following files:
.user.ini in the site root, change the path after auto_prepend_file
wordfence-waf.php in the site root, change the paths on all occurrences
WP Rocket plugin is installed
The file wp-content/advanced-cache.php contains system specific paths. You can manually update them or just simply delete the file and login to wp-admin of the site and it will be recreated automatically with the correct paths.
https://media01.nerdia.net/uploads/nerdia-logo-340x156.png00Stefan Helanderhttps://media01.nerdia.net/uploads/nerdia-logo-340x156.pngStefan Helander2020-03-01 09:20:402020-03-01 09:57:25WordPress shows white page after site move
In Windows 10 the user is asked to set a PIN-code for login instead of password. At login, the user can manually switch to password login each time. To completely disable PIN-code login, which also will disable fingerprint and face recognition login, do as follows:
Click on the Windows logo at the bottom left
Click on Settings (the gear icon)
Select Account
Click on Sign-in options
Click on PIN
Click on Remove
You will be asked for the user password
Don’t worry, if you want to enable it again you just follow the same steps but choose to install PIN.
https://media01.nerdia.net/uploads/nerdia-logo-340x156.png00Stefan Helanderhttps://media01.nerdia.net/uploads/nerdia-logo-340x156.pngStefan Helander2020-02-02 10:36:272020-02-02 10:36:27How to remove PIN-code login method in Windows 10